Not only when I acquired this error as soon as I need to adjust the Servlet version "Cannot change version of project facet Dynamic net Module to 3.1"
*

Step 1 - discover workspace place (optional)

If girlfriend don"t know where is her workspace located follow these steps:right click on the project;Click top top ResourceGo to her Location
*
My case: D:RepositoriesBitbucket rident-gaming.netJerseyHelloWorld

Step 3 - edit org.eclipse.wst.common.project.facet.core.xml file

Edit .settingsorg.eclipse.wst.common.project.facet.core.xml and adjust the jst.web property to 3.1.

Step 4 - Refresh and also Clean

Right-click top top the project and also refresh complied with by project -> Clean ... To recompile the project.

Step 5 - inspect the project facets

Going ago to task properties now it need to be 3.1.
*
These steps will work for any dynamic internet module version.